Gas Gauge issue

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

My78truck

'Ol Holly
Joined
Apr 7, 2019
Posts
298
Reaction score
231
Location
Virginia
First Name
Becky
Truck Year
1978
Truck Model
C10 Silverado
Engine Size
5.7L
I had my original sending unit replaced about 3 years ago because I had needle bounce when driving. Everything was fine, at least I thought, until today. I decided to drive my truck around today running as much of the gas out currently in the tank out without running out. I started at 1/2 tank and when I filled it after running around and doing errands ( a total of about 50 miles) the needle was registering at just about 1/8th tank. Went to "fill" my tank and I only had to put 8 1/2 gallons in. I know this is a 15 gallon tank. So if the guage registered 1/8th above empty, shouldn't I have had to put at least 12-13 gallons in my tank before it registered full? Because of how low the gas fill inlet is, I always get some splash back. I was manually holding the trigger and it splashed back. I waited about 15 seconds until things settled and then started pumping again at low volume and again got splash back. I do not!!!! want to take this someplace again and have the tank dropped again. This would explain how I can drive 20 miles and burn over 1/4 tank gas. The gauge is not registering. Is there anyway to calibrate the gas gauge?
 

Snoots

Full Access Member
Joined
Jan 23, 2013
Posts
8,286
Reaction score
16,356
Location
Georgia
First Name
Roger
Truck Year
1973
Truck Model
Jimmy Sierra
Engine Size
350
Likely a bad ground at the sensor. Check the input at the gauge and you should have about 90 ohms with a full tank, 0 at empty.
 

Latest posts

Forum statistics

Threads
42,912
Posts
924,488
Members
34,465
Latest member
NATE808
Top