1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Vince's TBI woes, progressive revelations, and tbi mods.

Discussion in 'TBI & EFI Conversions' started by Vbb199, Oct 21, 2020.

  1. Catbox

    Catbox Full Access Member

    Posts:
    1,435
    Likes Received:
    3,411
    Joined:
    Jul 12, 2018
    Location:
    Just Outside of Portland Oregon
    First Name:
    Peter
    Truck Year:
    1979
    Truck Model:
    C20 Silverado Camper Special
    Engine Size:
    461
    This thread just reminded me of what I found in the junkyard last week.
    I was looking for a throttle body to see how they work.
    What I found was this pile that was abused and corroded shut.

    This was a sign that it would be garbage right off the bat....

    20201101_121049.jpg
     
  2. Vbb199

    Vbb199 B-rate Hillbilly Customs

    Age:
    26
    Posts:
    6,171
    Likes Received:
    8,544
    Joined:
    Jan 12, 2018
    Location:
    Salisbury NC
    First Name:
    Vince
    Truck Year:
    91, 89, 87
    Truck Model:
    91 Blazer V1500- "K5ton", 87 K10 Suburban, 89 Suburban R1500
    Engine Size:
    502, 350, 350

    Can we discuss why there is a penumatic fitting where the fuel line shohld be?
     
    Catbox and bucket like this.
  3. bucket

    bucket Super Moderator Staff Member

    Age:
    39
    Posts:
    22,868
    Likes Received:
    9,056
    Joined:
    Aug 3, 2010
    Location:
    Usually not in Ohio
    First Name:
    Andy
    Truck Year:
    '77, '78, '79, '84, '88
    Truck Model:
    K5 thru K30
    Engine Size:
    350-454
    Yeah, that's what I'm wondering too.
     
  4. Vbb199

    Vbb199 B-rate Hillbilly Customs

    Age:
    26
    Posts:
    6,171
    Likes Received:
    8,544
    Joined:
    Jan 12, 2018
    Location:
    Salisbury NC
    First Name:
    Vince
    Truck Year:
    91, 89, 87
    Truck Model:
    91 Blazer V1500- "K5ton", 87 K10 Suburban, 89 Suburban R1500
    Engine Size:
    502, 350, 350
    Probably crossthreaded that in there and just used rubber line without hose clamps.
     
  5. Catbox

    Catbox Full Access Member

    Posts:
    1,435
    Likes Received:
    3,411
    Joined:
    Jul 12, 2018
    Location:
    Just Outside of Portland Oregon
    First Name:
    Peter
    Truck Year:
    1979
    Truck Model:
    C20 Silverado Camper Special
    Engine Size:
    461
    Bwahahahaa....
    You noticed that huh?
    There was also a socket stuck in the body of the thing.
    I removed both and kept them, left the throttle body though.

    Some people should just not work on cars.
     
  6. Vbb199

    Vbb199 B-rate Hillbilly Customs

    Age:
    26
    Posts:
    6,171
    Likes Received:
    8,544
    Joined:
    Jan 12, 2018
    Location:
    Salisbury NC
    First Name:
    Vince
    Truck Year:
    91, 89, 87
    Truck Model:
    91 Blazer V1500- "K5ton", 87 K10 Suburban, 89 Suburban R1500
    Engine Size:
    502, 350, 350
    Contacted my guy that burned my chip, he said he'd do me another one for my suburban with the 46mm tbi for just 40$. Which isnt bad. The first one was 75$. !

    Ill get that on order this week, and should i have time, install and see how she roars.
    More than likely ill need to a couple days down time to get everything tuned again
     
    Catbox likes this.
  7. Texxxan

    Texxxan Supporting Member Supporting Member

    Posts:
    66
    Likes Received:
    58
    Joined:
    Dec 2, 2019
    Location:
    Hooks, TX
    First Name:
    Jose
    Truck Year:
    1978
    Truck Model:
    C10
    Engine Size:
    350
    Wow!! Awesome work.
     
  8. 82sbshortbed

    82sbshortbed Fuckemall!!

    Posts:
    6,894
    Likes Received:
    18,237
    Joined:
    Mar 1, 2018
    Location:
    SE Texas
    First Name:
    Doug
    Truck Year:
    1982
    Truck Model:
    1500
    Engine Size:
    454
    Get chip yet?
     
  9. Vbb199

    Vbb199 B-rate Hillbilly Customs

    Age:
    26
    Posts:
    6,171
    Likes Received:
    8,544
    Joined:
    Jan 12, 2018
    Location:
    Salisbury NC
    First Name:
    Vince
    Truck Year:
    91, 89, 87
    Truck Model:
    91 Blazer V1500- "K5ton", 87 K10 Suburban, 89 Suburban R1500
    Engine Size:
    502, 350, 350
    Yeah, i sent you videos a couple weeks ago of the difference in acceleration i thought

    Or are you referring to the 46mm tbi chip?
     
  10. 82sbshortbed

    82sbshortbed Fuckemall!!

    Posts:
    6,894
    Likes Received:
    18,237
    Joined:
    Mar 1, 2018
    Location:
    SE Texas
    First Name:
    Doug
    Truck Year:
    1982
    Truck Model:
    1500
    Engine Size:
    454
    The one for the burb
     
  11. Rusty Nail

    Rusty Nail Re-Re-Elect TRUMP 2024

    Posts:
    6,799
    Likes Received:
    4,887
    Joined:
    Jan 29, 2015
    Location:
    Your mom's house
    First Name:
    Rusty
    Truck Year:
    1977,1988
    Truck Model:
    C20, K5
    Engine Size:
    350, 350
    Boom. Fixed.
    Oh wait....some letters....i learned this one time.....FIFY :badger_1: I think that's right :p 1.5 turns sounds like an eternity. :shrug:
     
    Vbb199 likes this.
  12. Vbb199

    Vbb199 B-rate Hillbilly Customs

    Age:
    26
    Posts:
    6,171
    Likes Received:
    8,544
    Joined:
    Jan 12, 2018
    Location:
    Salisbury NC
    First Name:
    Vince
    Truck Year:
    91, 89, 87
    Truck Model:
    91 Blazer V1500- "K5ton", 87 K10 Suburban, 89 Suburban R1500
    Engine Size:
    502, 350, 350
    Ok, so getting back at this again, now that i have time!
    I recently reset my idle back to 650-700 after all the changes i had made, i dropped plug gap back to .050, and set timing back at 0° for when i was towing to get rid of high ignition temps. Truck has been running AMAZING!

    Only issue ive had lately on and off is, ill get her fired up and running on a really cold morning, (despite being fuel injected, i refuse to run my motor down the road on cold mornings, i HATE doing that to my slug rings and cyl walls)

    Truck fires up, runs for a bit, suddenly turns off.... i crank and crank and crank and crank... FINALLY get it running i get a large puff of stinky gas smoke, and it runs.

    The OTHER issue ive had is, while idling at engine temps, it randomly drops (or increases) idle by 2-300 rpms.

    Either idles wherr i set it at 700, and almost stutters and dies and jumps to 900-1000, OR does the inverse.

    Now when shes idling at the 6-700, shes running like a scalded dawg.

    When idle is high, it runs like a turd.

    So i suspect timing and fueling.

    Whar controls those? MAP and CTS.

    Cts was replaced recently, didnt change a thing.


    So i did a little testing on my MAP just a bit ago.... check out the verdict in the video....



    As i suspected, i have a defunct map....

    Should be 5v @ signal wire, key on.
    At 5 in/hg i need to see around 3.7v
    And as i simulate idle (20-22in/hg), i should see 1v at signal.


    Sump'n is fucked up with that thang!
     
    Catbox likes this.
  13. Vbb199

    Vbb199 B-rate Hillbilly Customs

    Age:
    26
    Posts:
    6,171
    Likes Received:
    8,544
    Joined:
    Jan 12, 2018
    Location:
    Salisbury NC
    First Name:
    Vince
    Truck Year:
    91, 89, 87
    Truck Model:
    91 Blazer V1500- "K5ton", 87 K10 Suburban, 89 Suburban R1500
    Engine Size:
    502, 350, 350
    Ok.... so back to this heap of shit.
    Last we left off, the MAP was defunct, and @Rusty Nail suggested a new o2, which it needed anyways. Installed that last night, ALONG WITH a 180° thermostat. After talking with my tuner, he said the performance chip was burned for 180°.... so since the tbi relies heavily on the CTS signal.... i figured, what the hell, that might be rich issue... the former 160° thermostat always has it idling high.... guess what? Still didnt fix it.


    Heres where we stand:

    Something happens where the truck is constantly idling high, and when it does, performance goes down. Randomly sometimes, the truck will idle where i set it last, 650 or so, and when it idles correctly, the truck has got alot more power. Something is causing a rich condition, i just do not know what. No SES light. New map, new o2, new cts, no vacuum leaks (steady 22 in/hg), new distributor, coil, new iac, i relearned idle and manually set it. Timing is at 0° with plug disconnected. New knock sensor. ESC was swapped for known good one.


    Im still scratching my head. At times, the truck will be idling high, then SUDDENLY shuts off in idle, and i have to crank and crank and crank and crank, and FINALLY get it running and it blows out a bunch of raw stinky gas out the tailpipe..... im clueless .... i'm open to suggestions....




    Tomorrow i will be buying a bluetooth datalogger for the ALDL, and will be doing pulls for about 30 minutes, and then take the data, pull it up on the PC, and look it all over... theres something within the finer details the dumb SES signal isnt picking up... something causintlg a rich condition.

    The bluetooth device is 80$, and i can then log data directly from the ECM on a free android app open it and view it in a excell document.

    If i want to spend 20$ on ALDLDroid (app) i can take it a step further and see timing data at rpm intervals, and overall a much more detailed view. But FOR NOW, there is something much more obvious that my multimeter and vacuum gauge isnt picking up.

    Im hearing it, and smelling it.
    As i said, when it idles high performance is down. (Rich)

    When it idles like i set it, it runs like a fuckin champ.
    (More ideal, lean condition)
    The difference IS night and day.


    Im open to suggestions in the meantime.
     
    Catbox likes this.
  14. Vbb199

    Vbb199 B-rate Hillbilly Customs

    Age:
    26
    Posts:
    6,171
    Likes Received:
    8,544
    Joined:
    Jan 12, 2018
    Location:
    Salisbury NC
    First Name:
    Vince
    Truck Year:
    91, 89, 87
    Truck Model:
    91 Blazer V1500- "K5ton", 87 K10 Suburban, 89 Suburban R1500
    Engine Size:
    502, 350, 350
    I forgot to mention, TPS key on registers .68 volts, and has a smooth transition to WOT with the max output at like, 4.46v.
     
    Catbox likes this.
  15. Bextreme04

    Bextreme04 Full Access Member

    Posts:
    884
    Likes Received:
    867
    Joined:
    May 13, 2019
    Location:
    Oregon
    First Name:
    Eric
    Truck Year:
    1980
    Truck Model:
    K25
    Engine Size:
    350-4bbl
    Maybe you have an intermittent issue with the TPS? What about the seal around the throttle blade shaft? Can you wiggle it a bunch? Intermittent issues are the absolute worst things to troubleshoot... good luck man.
     
    Vbb199 likes this.

Share This Page