Need help with my 700r4

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

TJones

Junior Member
Joined
Sep 1, 2023
Posts
6
Reaction score
0
Location
Santa Rosa, CA
First Name
Timm
Truck Year
1983
Truck Model
k2500
Engine Size
5.7
Did a search and couldn’t really find what I was looking for. I’m getting my 83 k2500 on the road and on the initial drive first gear seems to shift a bit early into second. Second is strung out longer than I would like and takes about 4K rpm to shift to 3rd. 3rd seems to not shift into 4th and if I let off the gas and get back on the gas engine more or less revs up but no movement. Detent cable seems to be adjusted best can do until I can figure out why it shifts so quick in first but long shift in second. If I start coming to a stop seems like the granny is stuck in 3rd gear but if I come to a complete stop seems like it starts back out in 1st. It’s a 700r4 but unknown if it’s stock etc behind a blueprint 383. Any ideas?
 

Ricko1966

Full Access Member
Joined
Apr 11, 2017
Posts
4,595
Reaction score
6,943
Location
kansas
First Name
Rick
Truck Year
1975
Truck Model
c20
Engine Size
350
Sounds like you need a transmission or have yours rebuilt. There is no external adjustment or electrical fix. Sounds you lost 4th gear and have a valve body full of trash.
 

NickTransmissions

Supporting Member
Supporting Member
Joined
Aug 3, 2023
Posts
330
Reaction score
698
Location
Las Vegas
First Name
Nick
Truck Year
1987
Truck Model
R10
Engine Size
350
Did a search and couldn’t really find what I was looking for. I’m getting my 83 k2500 on the road and on the initial drive first gear seems to shift a bit early into second. Second is strung out longer than I would like and takes about 4K rpm to shift to 3rd. 3rd seems to not shift into 4th and if I let off the gas and get back on the gas engine more or less revs up but no movement. Detent cable seems to be adjusted best can do until I can figure out why it shifts so quick in first but long shift in second. If I start coming to a stop seems like the granny is stuck in 3rd gear but if I come to a complete stop seems like it starts back out in 1st. It’s a 700r4 but unknown if it’s stock etc behind a blueprint 383. Any ideas?
Your 3-4 pack is likely wasted; as @Ricko1966 said, it's time for a performance-oriented overhaul. You can perform a pressure test to see if the TV/detent cable is set up and adjusted correctly. Id also confirm your bracket is giving you the correct TV cable geometry if the carb that's installed is not a factory carb. The test will confirm or deny whether or not mal adjusted cable is an underlying cause of your internal failures.

How much power is your 383 making and how do you use this truck (daily driver, street strip, towing/heavy duty, etc)?
 

Latest posts

Forum statistics

Threads
42,984
Posts
926,006
Members
34,563
Latest member
chevyc10-1978
Top