Rebel turn signal

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

Subourbon

Full Access Member
Joined
Apr 28, 2020
Posts
89
Reaction score
55
Location
Quebec
First Name
Eric
Truck Year
1982
Truck Model
K20 suburban
Engine Size
6.2 V8
Hey all,

82 k20 suburban 6.2 diesel 4x4 here.
It started out as intermittent but, now it's constant.

With lights off: indicate left, turn signal clicks. Lights up forward work, but not in the rear. Turn signal self cancels. No issues anywhere else. Brakes reverse etc works. The clicking woth lights off us a tad slower than when I'm indicating right however

With lights on: everything is illuminated including problematic light (its not the light bulb). But when I indicate left, no more clicking noise, no flashing at the front nor at the rear. Indicator self cancels.

Now I replaced the bulb anyways just coz. No change. Can't imagine its in the fuse box coz there's one use for both side I believe.

That would lead me to think its in the light switch? Are those somewhat easy to work on or should I just replace the unit.

Unless one of you knows a trick...
Not really the end of the world I can definitely live with it for now but it'd be fun to have all lights working!

Let me know if you guys have any ideas... appreciate it everyone!
 

Subourbon

Full Access Member
Joined
Apr 28, 2020
Posts
89
Reaction score
55
Location
Quebec
First Name
Eric
Truck Year
1982
Truck Model
K20 suburban
Engine Size
6.2 V8
Oh, and hazards...

Lights off everything but rear left flashes.

Lights on everything but rear left flashes. So the front left seems to kick back on with flashers on. Fingers seem to really point at light switch.
 

Subourbon

Full Access Member
Joined
Apr 28, 2020
Posts
89
Reaction score
55
Location
Quebec
First Name
Eric
Truck Year
1982
Truck Model
K20 suburban
Engine Size
6.2 V8
Would it be the turn signal on the column, or the light switch module behind the bezel and dashboard though. That's what I'm not sure of now.
 

Goldie Driver

Full Access Member
Joined
Mar 19, 2018
Posts
3,936
Reaction score
6,397
Location
Houston, Texas
First Name
Britt
Truck Year
1980
Truck Model
GMC K1500 Suburban
Engine Size
350
I had a similar issue and the new bulb I had was bad. A new new bulb :cool:from the parts store solved the issue.

If that is not it then perhaps the socket is bad or the turn signal switch.

But, I would double check that bulb with new and put a little dielectric grease on the contacts.

You might just get lucky!
 

Subourbon

Full Access Member
Joined
Apr 28, 2020
Posts
89
Reaction score
55
Location
Quebec
First Name
Eric
Truck Year
1982
Truck Model
K20 suburban
Engine Size
6.2 V8
Goldie driver,,

Upon further inspection, the bulb that was already in there is fine. With lights in, there the running light/brake lights, and reverse. And the small turn signal bulb. And it's on. It just doesn't flash. So there's power going to it...someone said grounds. So tomorrow at first light il track down the grounds innthe rear and fingers crossed it'll work
 

Subourbon

Full Access Member
Joined
Apr 28, 2020
Posts
89
Reaction score
55
Location
Quebec
First Name
Eric
Truck Year
1982
Truck Model
K20 suburban
Engine Size
6.2 V8
It fixed itself. I messed around with the socket and light switch, so far it seems to be working.
Yay! Now I have a trans that won't shift in 3rd so gonna figure that out
 

Snoots

Full Access Member
Joined
Jan 23, 2013
Posts
8,252
Reaction score
16,247
Location
Georgia
First Name
Roger
Truck Year
1973
Truck Model
Jimmy Sierra
Engine Size
350
It didn't fix itself. It's foolin' you. Check that ground behind the light bezel to the socket.
 

Subourbon

Full Access Member
Joined
Apr 28, 2020
Posts
89
Reaction score
55
Location
Quebec
First Name
Eric
Truck Year
1982
Truck Model
K20 suburban
Engine Size
6.2 V8
Snoots,

You're probably right. It's in the shop actually since my last message lol. Rebuilding trans. Geez parts are hard to source.
I'll look into it when she's back home.
I miss my truck lol
 

Latest posts

Forum statistics

Threads
42,570
Posts
918,530
Members
34,110
Latest member
mundo
Top