81 C10 305 vacuum issues.

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

Ricko1966

Full Access Member
Joined
Apr 11, 2017
Posts
4,060
Reaction score
5,895
Location
kansas
First Name
Rick
Truck Year
1975
Truck Model
c20
Engine Size
350
True and exactly where my mind went, but I deserve 40 lashes because I changed out the TVS’s on my 85 305 only a year and a half ago. I shouldn’t have remembered that wrong let alone written “advice” about it.
No big deal man,I was just trying to keep the O.P. on the right track.
 

CopperLB81

Junior Member
Joined
Jan 13, 2024
Posts
5
Reaction score
1
Location
Biscoe NC
First Name
Bud
Truck Year
1981
Truck Model
C-10
Engine Size
305
Thanks to everyone for the advice, help, and comic relief.
AuroraGirl it has a Rochester M2ME 2bbl on it.
Ricko1966 the transmission is a th350c it does have lock up torque converter. Problem is I think that's the issue the trans vacuum switch on intake is unhooked no vacuum. Also for what I can see the modulator valve on trans has no vacuum going to it either. Previous owner put a billet or aluminum aftermarket servo on side of trans. Theres also a brass plug on passenger side of trans between servo and detent cable. I'll take some pics and post them so y'all can check it out.
 

AuroraGirl

Full Access Member
Joined
Sep 8, 2019
Posts
9,209
Reaction score
6,187
Location
Northern Wisconsin
First Name
Taylor
Truck Year
1978, 1980
Truck Model
K10, K25
Engine Size
400(?), 350
Thanks to everyone for the advice, help, and comic relief.
AuroraGirl it has a Rochester M2ME 2bbl on it.
Ricko1966 the transmission is a th350c it does have lock up torque converter. Problem is I think that's the issue the trans vacuum switch on intake is unhooked no vacuum. Also for what I can see the modulator valve on trans has no vacuum going to it either. Previous owner put a billet or aluminum aftermarket servo on side of trans. Theres also a brass plug on passenger side of trans between servo and detent cable. I'll take some pics and post them so y'all can check it out.
it definitely needs the modulator full stop before doing ANY driving
 

Forum statistics

Threads
42,087
Posts
908,638
Members
33,560
Latest member
bgeise
Top