Left Turn signal . doesn't work

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

Huckleberry

Junior Member
Joined
Jul 27, 2023
Posts
22
Reaction score
15
Location
Valley Bend WV
First Name
Donnie
Truck Year
1978
Truck Model
K15
Engine Size
350ci
Help need advisement! HELP. 1978 GMC K15. Left turn signal when turned on only lights up on dash as a solid light, no blink. Both left side turn signals front and back do not work, Right side turn signal is good. No running lights either side left or right???? in the back of the truck. Brake lights work, Hazzard lights ( 4way flashers) work good. I'm a novice at electrical issue at best. Hoping for some info, so if I have to take it to a shop, I'll at least have an idea. appreciate y'all.
 

Attachments

  • 20231117_165036.jpg
    20231117_165036.jpg
    277.1 KB · Views: 23
  • 20231117_165042.jpg
    20231117_165042.jpg
    206.2 KB · Views: 20
  • 20231117_165104.jpg
    20231117_165104.jpg
    209 KB · Views: 22

CountKrunk

Full Access Member
Joined
Aug 3, 2023
Posts
308
Reaction score
719
Location
ATL
First Name
Count
Truck Year
1984
Truck Model
C20 Custom Deluxe 3+3
Engine Size
v8 350
They were working or havent been since you got the truck?
 

AZ Highlander

Full Access Member
Joined
Nov 15, 2022
Posts
299
Reaction score
839
Location
Prescott AZ
First Name
Frank
Truck Year
1987
Truck Model
K15 (aka V1500)
Engine Size
350 (5.7L)
Yes, I also would like to know if they worked previously, if so, when and was anything done right before they stopped working?
Have you checked the fuses below the dash, by the parking brake yet?
We can help, but need to start there first to know more about the situation.
 

TotalyHucked

Full Access Member
Joined
Feb 24, 2020
Posts
2,713
Reaction score
8,787
Location
Auburn, Georgia
First Name
Zach
Truck Year
1985
Truck Model
Sierra 1500
Engine Size
5.3
Agreed, need more background. If they were working before and just quit, what were you doing when they quit?

I'd start by checking fuses and grounds first. Bad/dirty/loose grounds can cause all kinds of weird headaches. If all that checks out, I'd replace bulbs. Do the simple things first.
 

dvdswan

Full Access Member
Joined
Mar 11, 2014
Posts
2,366
Reaction score
2,024
Location
Port Orchard, WA
First Name
Dave
Truck Year
1978
Truck Model
K10
Engine Size
350
Burned out bulb on the front side marker would be my first check. Then check the grounds. Lights work, fuse is good. Stop/Tail/Turn is one fuse. Have you installed any new lights? or something that needs power?

You can download the 1978 wiring diagram here... https://www.gmsquarebody.com/threads/1973-1991-wiring-manuals.14498/

When checking grounds... they need to be clean (no rust/corrosion) and tight.

You must be registered for see images attach


Looks like a good connection. wrong. connectors have corrosion inside of them. This restricts the flow of voltage. The flow of electricity is like a garden hose. With all grounds in good condition water flows, if you step on the hose the volume of water goes down. Corrosion is just like that. You then don't get your 12v needed to operate something.

Don't check just the light grounds check body and engine grounds as well.

You must be registered for see images attach


You must be registered for see images attach


I would also check the grounds on the taillamps and if you have a trailer harness that too. As a matter of fact, if you have a trailer harness that is aftermarket or PO install. Check that first.
 

Jgonick

Full Access Member
Joined
Jan 12, 2017
Posts
197
Reaction score
262
Location
West Texas
First Name
Joel
Truck Year
1985
Truck Model
K10
Engine Size
350
Wrong or bad bulb, bad ground, & sometimes bad socket are usually the cause. So start by checking those first.

I know that sounds strange, but a wrong or bad bulb can cause a lot of weird issues.
-Start by looking at your front left turn signal (under headlight) & the left tail light (especially the dual filament bulb)- both of those are dual filament bulbs & are very important. They also play a role with the running lights.

Other important info to share for help. are you using LEDs? also What happens with turns signal with lights on vs light off.
 

Attachments

  • 78light.png
    78light.png
    257.2 KB · Views: 17
Last edited:

Huckleberry

Junior Member
Joined
Jul 27, 2023
Posts
22
Reaction score
15
Location
Valley Bend WV
First Name
Donnie
Truck Year
1978
Truck Model
K15
Engine Size
350ci
Sorry for the late response. Purchased truck last July. Everything was working just fine.
 

Huckleberry

Junior Member
Joined
Jul 27, 2023
Posts
22
Reaction score
15
Location
Valley Bend WV
First Name
Donnie
Truck Year
1978
Truck Model
K15
Engine Size
350ci
Fuses are good and replaced the turn signal relay. Still won't work. I ordered a new steering column switch. Watched some videos.... . Looks like a B***** to replace. Will start looking at the grounds as soon as the weather breaks.
 

75gmck25

Full Access Member
Joined
Oct 13, 2016
Posts
2,037
Reaction score
1,833
Location
Northern Virginia
First Name
Bruce
Truck Year
1975
Truck Model
K25 Camper Special TH350 NP203
Engine Size
5.7
Most likely to be either a bad bulb, or the ground at the turn signal housing. Also check the bulbs to make sure they are oriented correctly (one has two contacts), and are not corroded in the socket.
 

Huckleberry

Junior Member
Joined
Jul 27, 2023
Posts
22
Reaction score
15
Location
Valley Bend WV
First Name
Donnie
Truck Year
1978
Truck Model
K15
Engine Size
350ci
Got the truck fixed YEAHHHH. had 2 broken ground wires in the left rear side bumper. Pervious owner hacked job a trailer harness. Saving money to replace the whole thing. Thanks again to everyone for the help. Appreciate ya'll
 

Forum statistics

Threads
42,087
Posts
908,646
Members
33,560
Latest member
bgeise
Top