Turn signal issue- '76 C-10

Discussion in 'Tech Discussion' started by Will Aygarn, Oct 3, 2018.

  1. Will Aygarn

    Will Aygarn Junior Member

    Posts:
    1
    Likes Received:
    0
    Joined:
    Oct 2, 2018
    Location:
    Virginia Beach, Va.
    First Name:
    Will
    Truck Year:
    1976
    Truck Model:
    C-10
    Engine Size:
    250
    The front driver's side fender light & grille light works as running (parking) lights but they do not flash in turn signal mode.
    The other lights work fine in running light, turn signal, & 4-way flasher mode, but the front driver side lights don't flash.
    I tried swapping out the flasher units for G.P., but no change. Doesn't look like any of the fuses are blown.
    Looking at having to trace the wires hand over hand, unless somebody can suggest where to look first.
     
  2. Charlie

    Charlie Full Access Member

    Posts:
    878
    Likes Received:
    327
    Joined:
    Aug 2, 2017
    Location:
    Euless, Texas
    First Name:
    Don
    Truck Year:
    1974
    Truck Model:
    Cheyenne 10 LWB
    Engine Size:
    350/TH350/AC/4 BBL Quadrajet
    :welcome:
     
  3. 1987 GMC Jimmy

    1987 GMC Jimmy Full Access Member

    Age:
    21
    Posts:
    4,477
    Likes Received:
    1,081
    Joined:
    Jan 23, 2016
    Location:
    New Orleans, LA
    First Name:
    Jesse
    Truck Year:
    1987
    Truck Model:
    V1500 Jimmy
    Engine Size:
    350
    I suppose the chances are very slim, but have you checked the bulbs to make sure that one filament burned while the other one still works? A long shot, but I wanted to mention that. The wire that’d be causing you problems is gonna be that blue one. I’d be probing that as far back as I can to see where the wiring fault is. I don’t know if the turn signal switch in the column can fail in such a way as this. I’ve never heard of it, but someone else might know.
     

Share This Page