new here with an 87 short R10

87virginiaog

Junior Member
Joined
Aug 16, 2021
Posts
27
Reaction score
18
Location
new jersey
First Name
jason
Truck Year
1987
Truck Model
r10
Engine Size
5.7
so i went to virginia the other day and picked up an 87 r10- said to be second owner truck and 42k original miles. i had been looking and driving around my area for a while. jersey- went to new hampshire the week before to look at one but passed. anyway, now i once again own a square- short bed truck.

so the truck has a western chassis kit on it. so its low. and i love it.
it was my plan to buy a stocker and put a kit on it. so that parts done already.
trucks low and rides great- aside from the squeaky roll pan that is not welded.
no notch- but has heavy duty leaf springs im told and dont bottom out or hit anything much really. and since i dont plan to load truck or use as work truck. i may hold off on the notch for now.
question 1- i remember buying a kit for my old squares and obs trucks that came or i purchased shock extenders- for rear i believe- this truck does not have.
do i need? what is the purpose?

oil pressure guage didn't work - when i asked about it he said, not sure i ever seen one work in a square- in any event- yesterday i picked the sending unit up and swapped it out. stayed pegged past 60- then eventually i notice it dropped to around 40ish - then while the truck shifted i noticed it pegged again,
later almost stayed around the 40 ish level??? not sure whats going on there.

ac - factory and works - my 97 tahoe daily - dont. haha.

passenger window didn't work. fixed that yesterday.

paints not the greatest but i love the box and the paint dont bother me. one day- when i hit it big.....

check engine light i was told would come and go - o2 sensor i was told. so i got under there and noticed it was gone. a bolt in its place.
picked up a sensor yesterday and replaced- didn't see the light come on when i took a cruise with the wife after fixing a couple things.

exhaust- has a rattle from manifold heat shields- annoying. and question-
how hard to get headers on there ?? does it mean id need the entire exhaust re done afterwards???

i guess thats it for now. if i am posting in the wrong place please let me know.

and once i can get the pics from phone to get over to the computer. ill post pics of my new girl.

thanks for any help or advice.
 

Bextreme04

Full Access Member
Joined
May 13, 2019
Posts
2,921
Reaction score
2,876
Location
Oregon
First Name
Eric
Truck Year
1980
Truck Model
K25
Engine Size
350-4bbl
The PO might have some thick oil in there, that would cause the high pressures. You might also have the wrong sender paired with your gauge or a problem with the wiring.

My newly rebuild 350 runs 60+ PSI cold and around 40 at idle with 30w Lucas engine break-in oil in it. I bet they have something like 30W or 10-40 diesel oil in it. Thats still within normal pressure range though and shouldn't hurt anything. I'll be running 5w-30 in mine once it is fully broken in.
 

87virginiaog

Junior Member
Joined
Aug 16, 2021
Posts
27
Reaction score
18
Location
new jersey
First Name
jason
Truck Year
1987
Truck Model
r10
Engine Size
5.7
thanks for reply- diesel oil in a 5.7? not sure whats in there. or what would be ideal oil to run.
 

RedBeard_83

Full Access Member
Joined
Mar 16, 2020
Posts
554
Reaction score
850
Location
Florida
First Name
Cory
Truck Year
1986
Truck Model
Custom deluxe
Engine Size
Sbc 350
Welcome from florida
 

dvdswan

Full Access Member
Joined
Mar 11, 2014
Posts
2,088
Reaction score
1,551
Location
Port Orchard, WA
First Name
Dave
Truck Year
1978
Truck Model
K10
Engine Size
350
Welcome to the site. I was going to say that there are a lot of words and no pictures... but now. Nice truck.

Did you get an 80 psi oil switch or 60 psi?
 

87virginiaog

Junior Member
Joined
Aug 16, 2021
Posts
27
Reaction score
18
Location
new jersey
First Name
jason
Truck Year
1987
Truck Model
r10
Engine Size
5.7
Welcome to the site. I was going to say that there are a lot of words and no pictures... but now. Nice truck.

Did you get an 80 psi oil switch or 60 psi?

thanks for reply - and thanks all for the welcome- sorry for the size of the pics. but a few more
stock when the p.o purchased from the grandson of original owner.


You must be registered for see images attach

You must be registered for see images
 

87virginiaog

Junior Member
Joined
Aug 16, 2021
Posts
27
Reaction score
18
Location
new jersey
First Name
jason
Truck Year
1987
Truck Model
r10
Engine Size
5.7
another stock shot
You must be registered for see images attach
 

87virginiaog

Junior Member
Joined
Aug 16, 2021
Posts
27
Reaction score
18
Location
new jersey
First Name
jason
Truck Year
1987
Truck Model
r10
Engine Size
5.7
after swap - didn't know there were 2 options. went to autozone- asked for the part. had the old one with me luckily, they originally handed me one that would not fit my truck.

You must be registered for see images attach
 

dvdswan

Full Access Member
Joined
Mar 11, 2014
Posts
2,088
Reaction score
1,551
Location
Port Orchard, WA
First Name
Dave
Truck Year
1978
Truck Model
K10
Engine Size
350
Glad the gauge is normal now...
 

87virginiaog

Junior Member
Joined
Aug 16, 2021
Posts
27
Reaction score
18
Location
new jersey
First Name
jason
Truck Year
1987
Truck Model
r10
Engine Size
5.7
Glad the gauge is normal now...

not so sure its normal now. but took it for a ride today and spends most of the time in the 60 range but does come back to the 40 ish from time to time.

new question
700r4 - shifts a little hard going into 2nd. i drive like an old lady so i noticed it kind of kicks into 2nd. my wife pointed that out on yesterdays short cruise. got on it a bit gettin on a highway and smooth as butter. sometimes, it goes smooth. most times at a slow pace - kinda kicks into 2nd.

also, backed out of garage today and let her idle a bit- noticed smoke. passenger side valve cover was a little wet. put a napkin to it and color looked like trans fluid??? think it was dripping onto exhaust mani so causing smoke.- trans fluid? not what i was hoping for.

forgot- noticed something not plugged in today when i popped the hood, before seeing the smoking....


You must be registered for see images attach


smoke came from back end of valve cover gasket

You must be registered for see images attach


my rotted parts.....not sure if i need to source patch panels or a shop could just cut and make the patch parts.??? basically the worst of the truck is behind the wheel


You must be registered for see images attach


You must be registered for see images attach


now some shotty faded aged old paint- but gonna be a while before truck can get the paint it needs.....

You must be registered for see images attach


You must be registered for see images attach


You must be registered for see images attach


You must be registered for see images attach


You must be registered for see images attach


and lastly, that rattling ass roll pan.....

You must be registered for see images attach
 

Forum statistics

Threads
35,798
Posts
754,289
Members
24,796
Latest member
76 Longbed
Top