Go Back   GM Square Body - 1973 - 1987 GM Truck Forum > '73 - '87 GM Truck Modifications > Electrical & Audio
Become a Supporting Member         Become a Preferred Vendor

Advertisements

Electrical & Audio Electrical Accessories & Stereo Equipment.


User Tag List

Reply
 
Thread Tools Display Modes
Old Yesterday, 09:00 PM   #16
 
Georgeb's Avatar
Georgeb
Senior Member
 
Join Date: Apr 2015
Location: Wisconsin
Name: George
Age: 37
Posts: 2,920

Year: 2003
Model: K10 Burb Z71
Engine: 5.3

Rep Power: 32

Georgeb is a splendid one to beholdGeorgeb is a splendid one to beholdGeorgeb is a splendid one to beholdGeorgeb is a splendid one to beholdGeorgeb is a splendid one to beholdGeorgeb is a splendid one to behold
Mentioned: 30 Post(s)
Tagged: 0 Thread(s)
Default
Originally Posted by 87silveradok20 View Post
ok wow i did not know that. i will try turning the lights on and see if that changes things
I don't think that will change anything. You are going to need to set aside a chunk of time and systematically check each item Chengny outlined earlier. You have a short between the right and left signal wires somewhere and you need to trace them from the turn signal switch to the front lamps including the leads up to the cluster.

Georgeb is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn signal issue 77 K20 Electrical & Audio 5 03-06-2017 11:42 PM
Turn Signal Issue vicnation Electrical & Audio 6 12-06-2016 10:38 AM
turn signal mystery clark76 Electrical & Audio 2 04-22-2015 11:12 PM
turn signal fuse juanichi214 Electrical & Audio 2 01-12-2015 02:33 PM
turn signal problems fowjacob Electrical & Audio 8 08-29-2012 10:46 PM